Commit 42ba120e authored by antoine masson's avatar antoine masson
Browse files

backv1.11

compression does not work
parent ff483efa
...@@ -6,7 +6,6 @@ const bodyParser = require('body-parser'); ...@@ -6,7 +6,6 @@ const bodyParser = require('body-parser');
const morgan = require("morgan"); const morgan = require("morgan");
const DEBUG = require('debug')('API:index'); const DEBUG = require('debug')('API:index');
const fileUpload = require('express-fileupload'); const fileUpload = require('express-fileupload');
const compression = require('compression')
// const zip = require('express-zip'); // const zip = require('express-zip');
...@@ -37,8 +36,7 @@ mongoose.connect( ...@@ -37,8 +36,7 @@ mongoose.connect(
SurveyController.initSurveyTemplate(); SurveyController.initSurveyTemplate();
const index = express(); const index = express();
index.use(compression);
index.use(morgan("dev")); index.use(morgan("dev"));
index.use(cors()); index.use(cors());
index.use(bodyParser.json({limit: "50mb"})); index.use(bodyParser.json({limit: "50mb"}));
......
{ {
"name": "api", "name": "api",
"version": "1.1.2", "version": "1.1.1",
"description": "", "description": "",
"main": "index.js", "main": "index.js",
"scripts": { "scripts": {
...@@ -10,7 +10,6 @@ ...@@ -10,7 +10,6 @@
"dependencies": { "dependencies": {
"bcrypt": "^5.0.0", "bcrypt": "^5.0.0",
"body-parser": "^1.19.0", "body-parser": "^1.19.0",
"compression": "^1.7.4",
"cookie-parser": "~1.4.4", "cookie-parser": "~1.4.4",
"cors": "^2.8.5", "cors": "^2.8.5",
"debug": "~2.6.9", "debug": "~2.6.9",
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment