Commit 948c0a21 authored by haemmer's avatar haemmer

Corrected and clarified requirements section due to #1846

parent f40fb5ad
...@@ -15,16 +15,19 @@ information. ...@@ -15,16 +15,19 @@ information.
------------------------------------------------------------------------------- -------------------------------------------------------------------------------
Requirements: Requirements:
- The web server must support PHP5 - PHP 5.3 or newer
- If the configuration and the backup configuration differ, you have to make - PHP XML Parser extension is required for parsing SAML2 metadata
sure the user that runs the php script has write access for the configuration - The web server users must have write permissions to some files including:
files. * $backupIDPConfigFile (default 'IDProvider.conf.php')
- PHP XML Parser extension for parsing SAML2 metadata * $metadataIDPFile (default 'IDProvider.metadata.conf.php')
* $metadataSPFile (default 'SProvider.metadata.conf.php')
* $metadataLockFile (default '/tmp/wayf_metadata.lock')
* $WAYFLogFile (default '/var/log/apache2/wayf.log')
------------------------------------------------------------------------------- -------------------------------------------------------------------------------
Installation: Installation:
1. Unpack the Zip archive into a directory on a host where Apache 1. Unpack the SWITCHwayf_binary ${VERSION}_${DATE}.zip ZIP archive into a
(IIS also should work) is deployed. directory on a host where Apache or IIS is installed.
2. Make a copy of the *.dist.php files 2. Make a copy of the *.dist.php files
- Copy the file config.dist.php and name it config.php - Copy the file config.dist.php and name it config.php
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment